Need Help - Communication with Ingenico i5100

More
11 years 9 months ago #12368 by itsjamesD
Dear Pete and All the programmers,

I've read from the previous thread about communication with ingenico I3070 and others 6 series and I tried with all of that method and driver including the one in your attachment (OPOS Driver) and also your dot net sample program but until now seems like I haven't be able to communicate with the device at all, I've set the port com1 to be match with the PC , but still I'm not be able to communicate with the device, I used usb cable to connect to my PC (with cable convert from COM to USB). I tried to communicate with the device, I can sent the data on com port 1 using serialport on vb.net but I did not receive any respond or data., is it because of I need some encoding or protocol like UNICAPT32 then I will be able to communicate with the device and get response ? Please help me to be able to communicate with ingenico i5100.

Thank You,

James

Please Log in or Create an account to join the conversation.

More
11 years 9 months ago #12369 by Pete
Hey James,

99% of the time this problem indicates that you don't have your communication method configured correctly on the device (COM vs USB). It's not enough to just plug the cable into the device. You have to change the settings to also use that method. Refer to your device manual on how to do that.

Pete

DigiOz Webmaster
www.digioz.com

Please Log in or Create an account to join the conversation.

More
11 years 9 months ago #12370 by itsjamesD
Hi Pete,

Thank you for your response, I have this device with me without the manual and I tried to find it online but all I got is just the manual for the specification and user guide to start up the device. I entered to SSA menu and change the settings to used COM port 1 as a default communication but still no luck, I even tried to make the device on download state and sent some random command and the device display shown an error when receive the data, that means the communication and the driver (prolific usb to serial) is working to transmit the data, or else is there any protocol standard or encoding method that I need to follow to sent the instruction through rs232 for this ingenico i5100? or any special command or instruction that you know which is working and the device will sent me back some response. I'm so curious why I can't get any response.

Thank you,

James

Please Log in or Create an account to join the conversation.

More
11 years 9 months ago #12375 by Pete
Unfortunately we no longer have either the manual or the Ingenico devices here in the office, so the extend of help I can provide you is from my memory.

Pete

DigiOz Webmaster
www.digioz.com

Please Log in or Create an account to join the conversation.

Time to create page: 0.115 seconds
Powered by Kunena Forum